Soru Dosya ya da derleme yüklenemedi. Crdb_adoplus.dll


Aşağıdaki hata için:

Dosya veya derleme Co dosyası yüklenemedi: /// C: \ Program Files \ SAP BusinessObjects \ SAP BusinessObjects Enterprise XI 4.0 \ win32_x86 \ dotnet1 \ crdb_adoplus.dll 'veya bağımlılıklarından biri.

Bu hatayı çözüm yolundan çözmek için herhangi bir yolu var mı:

<startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0"/>
</startup>

Bu çözüm benim uygulamamda çalışmıyor


34
2017-07-06 19:19


Menşei




Cevaplar:


Lütfen bu kodu kullanın. Bu sizin için yararlı olabilir.

<startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
</startup>

Bu senden biraz farklı. Daha fazla detay için bu bağlantıyı ziyaret edin Crystal Report Viewer


73
2017-12-20 07:48



Teşekkürler, benim için çalıştı. Tekrar teşekkürler. - Priyankara
"Bu senden biraz farklı!" Kesinlikle! - Ali Bagheri Shakib
Benim için çalıştı (.net 4.6.1) - Liquid Core
Benim için çalıştı, teşekkürler, bunun neden olduğunu açıklayabilir misiniz? - Osama Gadour
Sadece <startup> <startup useLegacyV2RuntimeActivationPolicy = "true"> değerine ihtiyacım var. - midohioboarder


Başarılı çalışmak için ilk satırı değiştirin

Solution Explorer'dan "App.config" dosyasını açtıktan sonra

Önceki:

<startup> 

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5"/></startup>

Güncel:

<startup useLegacyV2RuntimeActivationPolicy="true">

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5"/></startup>

10
2017-09-26 01:18



baş ağrısı beni kurtardı basit açıklama için teşekkür ederim :) - Hazmat


SBO SDK'nizin farklı bileşenleri arasında, farklı .NET sürümüne sahip derlemeler de vardır. Makinenizde SAP BO SDK'nın eski bir sürümü yüklü olup olmadığını kontrol edin. Bu yardımcı olur umarım.


2
2017-07-06 19:26





Sadece kullan

<startup useLegacyV2RuntimeActivationPolicy="true">
</startup>

Tüm çerçeveler için çalışıyor!


2
2017-07-31 16:51



benim için çalıştı Ty - Myk Agustin


Aşağıdaki kodu app.config veya web.config dosyanıza eklemeyi deneyin:

<startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0"/>
</startup>

1
2018-03-28 07:52





Adımları izleyin:  Projeye sağ tıkladıktan sonra özellikler -> derleme -> Gelişmiş Derleme Seçeneğine tıklayın. -> Hedef çerçeveyi tıklayın ve .Net Framework 3.5 -> Şimdi Tamam'ı tıklayın.

Bu basit çözüm.


0
2017-08-12 16:53





ASP.Net uygulamasında bu soruna bakarken, uygulamanın uygulama havuzunu IIS'de kontrol edin. Uygulama havuzunu .Net 4.0'dan .Net 2.0'a değiştirin.

Bu sorunu çözecektir.


0
2017-10-29 23:59