Soru npm ERR! ağ getaddrinfo ENOTFOUND


alıyorum npm ERR! network getaddrinfo ENOTFOUND NPM kullanarak herhangi bir paket yüklemeye çalışırken hata. Aynı konuda çok sayıda iş parçacığı olduğunu biliyorum, ancak bana yardımcı olabilecek herhangi bir iş parçacığı bulamadım.

Ben proxy ayarladım & doğru url kullanarak değil doğru ayarlanmış değil vekil ile ilgili bir şey düşünüyorum.

npm config set proxy http://proxy.company.com:8080
npm config set https-proxy http://proxy.company.com:8080

Proxy'yi ayarlarken kullandığım URL'yi kontrol etmenin bir yolu var mı? Bu sorunu düzeltmek için atmam gereken adımlar var mı?

enter image description here


28
2018-04-21 08:21


Menşei




Cevaplar:


Belki de vekilin ayakta durmaması https. Yaptığım şey ~ / .npmrc'nin proxy içeriğini temizlemek veya kullanmak

    npm config delete proxy

Daha ne, NRM Bu sorun için önerilir.


21
2017-10-29 07:43



Bu çözüm için teşekkürler - Gopinath Kaliappan


Kullanarak proxy'yi ayarlamak yerinenpm config set http_proxy=http://address:8080 ~ / .npmrc adresine gidin ve proxy yapılandırmasını kaldırın. Bu benim sorunumu çözdü.


8
2017-10-23 14:37





Proxy'yi ayarlıyordum

npm config set http_proxy=http://domain:8080

doğru yolu kullanmak yerine

npm config set proxy http://domain:8080

8
2018-04-23 10:04



Görüntüleyenlere not: Proxy'nin şu şekilde başladığından emin olun: http:// ve sadece yazmayın someHost:1234! - izogfif


Bu hatayı da gördüm ama şu anda bir proxy sunucusunun arkasında çalışmıyordum. npm config set proxy=http://address:8080 yardım edemedim ~/.npmrc herhangi bir proxy ayarını da içermedi. Benim durumumdaki çözüm sadece bilgisayarımı yeniden başlat.


4
2018-03-18 15:33





Proxy'niz kimlik doğrulamanızı gerektirir mi? Çünkü eğer varsa, proxy'nizi bu şekilde yapılandırmanızı isteyebilirsiniz.

yer tutucu adları. Kullanıcı adı gerçek kullanıcı adınız için bir yer tutucudur. parola gerçek şifreniz için bir yer tutucudur. proxy.company.com senin gerçek vekil için bir yer tutucudur * port "senin gerçek portu vekalet geçer. onun her zamanki 8080

npm config set proxy "http://username:password@proxy.company.com:port"
npm config set https-proxy "http://username:password@proxy.company.com:port"

1
2018-01-08 06:33



Bu oydu! Alanımı tüm zamanlar kullanıcı adımın önünde buldum. - Ruan


Yanlış adres olarak yazdım.

http://addressOfProxy.8080

yerine

http://addressOfProxy:8080  

(Dikkat edin kolon 8080 numaralı bağlantı noktasından önce.)


0
2017-10-27 18:50





Öncelikle, proxy'nin benim için ayarlanıp ayarlanmadığını veya kullanmadığını kontrol ediyorum:

npm config get proxy

Null döndü, sonra bu komutu çalıştırıyorum

npm config set strict-ssl=false

Bu cmd oturumu için sıkı ssl'yi devre dışı bırakır.

Bunu kullanarak tüm yapılandırma listesini görebilirsiniz.

npm config list ls -l

0
2018-04-17 05:57





1. Adım: Proxy'yi ayarlayın npm proxy ayarla http: // kullanıcıadı: companyProxy @ şifre: 8080

npm https-proxy'yi ayarladı http: // kullanıcıadı: companyProxy @ şifre: 8080

npm config set katı-ssl yanlış -g

NOTLAR: @ ​​şifresi dışında @ izin verilen özel karakterler yoktur.


0
2017-07-24 07:23





Sıkı-ssl = false

proxy = http: // ip_address_of_proxy: 8088    https-proxy = http: // ip_address_of_proxy: 8088
  kayıt defteri = http://registry.npmjs.org/


-1
2017-08-13 12:15