Soru kotlin.jvm.KotlinReflectionNotSupportedError: Kotlin yansıma uygulaması çalışma zamanında bulunamadı. Kotlin-reflect.jar olduğundan emin olun.


Derlediğimde yukarıdaki hatayı aldım. Benim gradle dosya aşağıdaki gibi: -

apply plugin: 'com.android.application'
apply plugin: 'kotlin-android'
apply plugin: 'kotlin-android-extensions'

android {
    compileSdkVersion 23
    buildToolsVersion "24.0.0 rc2"

    defaultConfig {
        applicationId "package.name"
        minSdkVersion 16
        targetSdkVersion 23
        versionCode 6
        versionName "2.0"
    }

    buildTypes {
        debug {
            minifyEnabled false
            signingConfig signingConfigs.debug
        }
        release {
            minifyEnabled true
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
            signingConfig signingConfigs.release
        }
    }
    sourceSets {
        main.java.srcDirs += 'src/main/kotlin'
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile "com.android.support:appcompat-v7:$support_version"
    compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version"
    compile "org.jetbrains.anko:anko-sdk15:$anko_version"
    compile "org.jetbrains.anko:anko-support-v4:$anko_version"
    compile "com.android.support:recyclerview-v7:$support_version"
}

buildscript {
    ext.kotlin_version = '1.0.1-2'
    repositories {
        jcenter()
        mavenCentral()
    }
    dependencies {
        classpath "org.jetbrains.kotlin:kotlin-android-extensions:$kotlin_version"
    }
}
repositories {
    mavenCentral()
}

Ve benim projem aşağıdaki gibi

buildscript {
    ext.support_version = '23.2.1'
    ext.kotlin_version = '1.0.1'
    ext.anko_version = '0.8.3'
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.1.0-alpha3'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Bir şey ekledim mi?


25
2018-04-06 02:16


Menşei




Cevaplar:


Hatadan, varsayalım:

compile "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version"

senin içinde dependencies standart kütüphaneye ek olarak.


53
2018-04-06 02:20



Teşekkürler! İhtiyacımız bulundu compile "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version" testCompile "org.jetbrains.kotlin:kotlin-test:$kotlin_version" göre kotlinlang.org/docs/reference/using-gradle.html - Elye
Alternatif olarak, kodunuzda Kotlin yansımasını kullanmayın, o zaman kotlin yansıma bağımlılığına ihtiyacınız yoktur. - Kirill Rakhman
Belki de belli değil: (1) tek tırnaklı, çift tırnaklı olmalı, aksi halde $ kotlin_version genişlemeyecek, (2) kotlinlang.org/docs/reference/... : $ kotlin_version,> = 1.1.2 ise ihmal edilebilir. Ama bu benim için kırılmış gibi görünüyor ($ kotlin_version şu anda 1.2.10); hata mesajı, bunun gibi bir sahte URL oluşturduğunu gösterir. https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-reflect//kotlin-reflect-.jar. Yani, hala bu cevapta tarifi kullanıyorum. - Don Hatch
Bahsetmeye değer implementation şimdi tercih edilen direktiftir compile: implementation "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version" - kip2