Soru Özel Belge Kökü ile Apache 2.4'te Dizin Dizini nasıl gösterilir


Ubuntu 13.10'da Apache 2.4'te sorun yaşıyorum. Document Root'u / home / fandi / public_html olarak değiştirmeyi deniyorum Ve her şey yolunda. Ama public_html / i dizininde klasör oluşturmaya çalışıyorum.

[Sat Jan 25 10:59:50.149441 2014] [autoindex:error] [pid 1093] [client 127.0.0.1:39901] AH01276: Cannot serve directory /home/fandi/public_html/report_php/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive

Dosya oluşturmalıyım index.html, index.php ve diğeri index.xxx dosya.

Varsayılan olarak Dizin Dizini göstermelidir. Dizin Dizini nasıl etkinleştirilir?

Bu benim dosyam 000-default.conf :

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /home/fandi/public_html

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    <Directory "/home/fandi/public_html">
        Options All
        AllowOverride All
        Require all granted
        Options Indexes FollowSymLinks
    </Directory>

</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Lütfen yardım, önce teşekkürler


18
2018-01-25 04:08


Menşei


Bunun neden php veya ubuntu olarak etiketlendiğinden emin değil - bu saf bir Apache sorusu - gotofritz


Cevaplar:


Otomatik Dizinleri almak için Apache 2.4'te DirectoryIndex'i devre dışı bırakmanız gerektiğine karar verir.

DirectoryIndex disabled
Options Indexes

DirectoryIndex devre dışı bırakılmadığında, auto indeksi çalışmaz ve fastcgi / php-fpm kullanırsanız apache 403 Yasaklandı veya 404 Dosyası bulunamadı.

İşte ilgili hata kaydı satırları (arama amaçları için):

[authz_core:error] client denied by server configuration:
[proxy_fcgi:error] Got error 'Primary script unknown\n'

8
2017-08-01 12:34



Hizmet vermeme / usr / share / apache2 / icons / başarısızlıklarının bir yerde bazı otomatik test paketlerinden alındığını düşünürdüm. alias.conf ... / simgeler / varsayılan olarak hala vardı [autoindex: error] ... AH01276: Dizin / usr / share / apache2 / icons / Thank You! - rjt
Benim için sorun buydu. DirectoryIndex'i önce devre dışı bırakmalısınız - Brady
Bu benim için hiçbir şey yapmadı. - gotofritz
Teşekkür ederim! Sonunda çalışan bir şey! - o01
DirectoryIndex'i devre dışı bırakacak bilgi yok. - user1


Options All <--turn on all options
Options Indexes FollowSymLinks   <--- replace previously set options with these two

İkinci satır gereksizdir, çünkü tüm seçenekleri ilk satırda zaten açmışsınızdır ve iki seçenek öntanımlı değildir. +, aslında ayarlanmış tüm seçenekler listesini REPL All sadece bu iki bireysel seçenek ile.


6
2018-01-25 04:11



Peki, nasıl düzenlemeliyim? Daha önce sadece kullanıyorum Options All ve şimdi sadece kullanmaya çalışıyorum Options Indexes FollowSymLinks ama işe yaramadı. : \ - fanjavaid
Benim için çalışmadı. Apache 2.4 aniden baş ağrıyor ve 10 yılı aşkın bir süredir apache ile çalışıyorum. Sorun şu ki, google'ı denerseniz, tüm WRONG olan 2.2 için son 10+ yıldan cevaplar alırsınız. - laapsaap


İşe almak başardı

Temel olarak, Apache2.4'ün, sanal konaklar, önceki sürümlerin yaptığı gibi, DocumentRoot'un alt klasörleri olmadıkça, DocumentRoot'tan sanal ana makinenize ayarları taşımadığı görülmektedir. Ne tür bir anlam ifade eder, ancak değişiklik belgelenmeli ve değişmedi.

Demek istediğim, httpd.conf dosyanızda (bu bir OS X olan):

DocumentRoot "/Library/WebServer/Documents"
<Directory "/Library/WebServer/Documents">
    Options +Indexes +FollowSymLinks
    # etc
</Directory>

Ve sonra ekstra / httpd-vhosts.conf

<VirtualHost *:80>
    DocumentRoot "/pth/to/somewhere/completely/different"
    ServerName my-virtual-host.dev
    ErrorLog "/private/var/log/apache2/my-virtual-host.dev-error_log"
    CustomLog "/private/var/log/apache2/my-virtual-host.dev-access_log" common
</VirtualHost>

VH, tüm ayarları devralır - artık alt klasör değilse. Yani yapmanız gereken şey, VH'de ayarları kopyalayıp yapıştırmak (veya muhtemelen başka bir tane yaratabilirsiniz) <directory Aynı yerde çok fazla VH varsa

<VirtualHost *:80>
    DocumentRoot "/pth/to/somewhere/completely/different"
    ServerName my-virtual-host.dev
    ErrorLog "/private/var/log/apache2/my-virtual-host.dev-error_log"
    CustomLog "/private/var/log/apache2/my-virtual-host.dev-access_log" common
    <Directory "/pth/to/somewhere/completely/different">
        Options +Indexes
    </Directory>
</VirtualHost>

Büyüyü yapan + Indexes.


5
2018-03-06 22:35



Debian 8.0 Jessie's Apache'de (2.4) açıkça eklemek gerekiyor DocumentRoot /var/www senin için /etc/apache2/apache2.conf kendi belge kökleriyle birden çok sanal ana bilgisayara hizmet veriyorsanız. - TranslucentCloud


Centos 7.2 ve apache 2.4 ile aynı sorun vardı.

Yeni yüklemede, sorun büyük olasılıkla welcome.conf her konumda Seçenek Dizinlerini devre dışı bırakan:

<LocationMatch "^/+$">
    Options -Indexes
    ErrorDocument 403 /.noindex.html
</LocationMatch>

Bu dosya her Apache güncellemesinde geri yüklenir, daha sonra önceki satırları yorumlamalı veya silmelisiniz.


5
2017-08-30 22:34





Günlükte bir hata bulabilirsiniz

[Sun Dec 03 17: 38: 17.649269 2017] [autoindex: hata] [pid 4806] [client :: 1: 57323] AH01276: / etc / httpd / conf / htdocs dizinine / dizinine sahip olamaz: / DirectoryIndex () eşleşen eşleşme bulunamadı ve Options yönergesi tarafından yasaklanan sunucu tarafından oluşturulan dizin dizini

Tamir etmek için:-

sonra /etc/httpd/conf.d/welcome.conf dosyasındaki satırı kaldırmanız gerekir.

Mevcut konfigürasyonun altında: -

<LocationMatch "^/+$">
   Options -Indexes
    ErrorDocument 403 /.noindex.html
</LocationMatch>

aşağıdaki yapılandırma ile çözüldü, - bir çizgi yorumladı.

<LocationMatch "^/+$">
   #Options -Indexes
    ErrorDocument 403 /.noindex.html
</LocationMatch>

1
2017-12-03 16:47





Bu satırı siteye ait vhost.conf dosyasına ekleyin

DirectoryIndex default.html

Ve sen hepiniz ayarlandınız


0
2018-06-24 13:01





gelecekteki insanlar için, yukarıdakileri takip ederseniz ve hala sorun çıkarsa, şunu deneyin:

httpd.conf(make sure belows are open):
LoadModule alias_module modules/mod_alias.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule autoindex_module modules/mod_autoindex.so
Include conf/extra/httpd-autoindex.conf

Ekstra / httpd-autoindex.conf:

<Directory "change to your directory">

0
2018-03-04 04:48