Soru Artifact org.apache.maven.plugins aktarılamadı: maven-surefire-plugin: pom: 2.7.1 / dan merkezi (http://repo1.maven.org/maven2)


SpringSource Tool Suite'de yeni bir maven projesi oluşturdum. Bu hatayı yeni bir maven projesinde alıyorum.

Aktarılamadı   org.apache.maven.plugins: maven-surefire-eklenti: pom: 2.7.1 dan    http://repo1.maven.org/maven2 yerel depoda önbelleğe alındı,   Güncelleme aralığına kadar çözünürlük reddedilmeyecek   merkezi geçti veya güncellemeler zorlandı. Orijinal hata: Could not   aktarma eseri   org.apache.maven.plugins: maven-surefire-eklenti: pom: 2.7.1 dan / e'ye   merkez (http://repo1.maven.org/maven2): Zaman aşımına uğruyor

pom.xml:

<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                             http://maven.apache.org/xsd/maven-4.0.0.xsd">

  <modelVersion>4.0.0</modelVersion>

  <groupId>com.test.app</groupId>
  <artifactId>TestApp</artifactId>
  <version>0.0.1-SNAPSHOT</version>
  <packaging>jar</packaging>

  <name>TestApp</name>
  <url>http://maven.apache.org</url>

  <properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
  </properties>

  <dependencies>
    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
    </dependency>
  </dependencies>
</project>

settings.xml

<?xml version="1.0" encoding="UTF-8"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" 
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
  <pluginGroups>
  </pluginGroups>
 <proxies>
    <proxy>
      <id>optional</id>
      <active>true</active>
      <protocol>http</protocol>
      <username>user</username>
      <password>pass</password>
      <host>ip</host>
      <port>80</port>
      <nonProxyHosts>local.net|some.host.com</nonProxyHosts>
    </proxy>    
  </proxies> 
  <servers>  
  </servers>
    <mirrors>   
    <mirror>
      <id>mirrorId</id>
      <mirrorOf>repositoryId</mirrorOf>
      <name>Human Readable Name for this Mirror.</name>
      <url>http://repo1.maven.org/maven2/</url>
    </mirror>    
  </mirrors>  
<profiles>
 </profiles>
</settings>

Lütfen bunu yapabildiğimden emin değilim.Error, IDE .Any çözümleri içinde pom.xml içinde gösteriliyor mu?


44
2018-03-11 08:50


Menşei


Vekilin arkasında mısın? - Sam Rad
Bir proxy ayarlamanız mı gerekiyor? - Derek
Bir vekilin arkasında olmadığına emin misin? - Anubhab
Bize çıkışını göster mvn help:effective-settings yanı sıra pom.xml. - carlspring
Bu benim sistemimde başka maven projelerine sahip olduğumdan ve her şeyin iyi çalıştığından dolayı, ayarlarla ilgili bir sorun değil gibi görünüyor. Bu, yeni bir uygulama oluşturmaya çalıştığımda oluyor. - Sajith


Cevaplar:


Aşağıdakileri kullanarak işleri basitleştirin settings.xml:

<?xml version="1.0" encoding="UTF-8"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" 
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                              http://maven.apache.org/xsd/settings-1.0.0.xsd">

 <proxies>
    <proxy>
      <id>myproxy</id>
      <active>true</active>
      <protocol>http</protocol>
      <username>user</username>  <!-- Put your username here -->
      <password>pass</password>  <!-- Put your password here -->
      <host>123.45.6.78</host>   <!-- Put the IP address of your proxy server here -->
      <port>80</port>            <!-- Put your proxy server's port number here -->
      <nonProxyHosts>local.net|some.host.com</nonProxyHosts> <!-- Do not use this setting unless you know what you're doing. -->
    </proxy>    
  </proxies> 
</settings>

Linux / Unix altında, altına yerleştirin ~/.m2/settings.xml. Altında Windows altına yerleştirin c:\documents and settings\youruser\.m2\settings.xml veya c:\users\youruser\.m2\settings.xml.

İhtiyacın yok <mirrors/>, <profiles/> ve <settings/> bölümleri, gerçekten ne için olduklarını bilmiyorsanız.


41
2018-03-11 10:06



Yardımınız için teşekkürler. Yine de aynı hatayı alıyorum. Yapabildiğimi not etmeyin. Hata sadece IDE'de. - Sajith
Tamam o zaman. IDE'nizde, aynı şeyi işaret ettiğinden emin olun. settings.xml Proxy ayarlarınız IDE'niz tarafından algılanmadığından dosya. - carlspring
müthiş. Teşekkürler - arn-arn


Bu, maven'i güncellediğimde ve Eclipse'deki "Anlık Görüntüler / Sürümlerin Güncellemesini Zorla" seçeneğini işaretlediğimde benim için çözüldü. Bu tüm hataları temizler. Projeyi sağ tıklayın -> Maven -> güncelleme projesi, ardından yukarıdaki seçeneği işaretleyin -> Tamam. Umarım bu size yardımcı olur.


31
2018-05-27 10:36



Teşekkürler, benim için de çalıştı. - another
Bu benim için çalışıyor, ama Eclipse'i yeniden başlatmalıyım. - ceklock
teşekkürler, işe yaradı :) - BleedCode
Teşekkürler, benim için çalıştı. Eclipse'i bir makineden diğerine kopyaladım ve maven yerel önbelleği benim için arkasındaki sorun gibi görünüyor. Sanpshot'ı güncellediğimde, benim için çalıştı. - Manoj


Maven'in Maven deposuna bağlanılamıyor gibi görünüyor. http://repo1.maven.org/maven2.

Proxy kullanıyorsanız ve tarayıcıya olan bağlantıya erişebiliyorsanız, Spring Source Tool Suite'e (eğer suitte çalışıyorsanız) veya Maven'e aynı ayarların uygulanması gerekir.

Maven proxy ayarı için bir settings.xml içinde .m2 aşağıdaki detayları içeren dizin

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                      http://maven.apache.org/xsd/settings-1.0.0.xsd">
  <proxies>
    <proxy>
      <active>true</active>
      <protocol>http</protocol>
      <host>PROXY</host>
      <port>3120</port>
      <nonProxyHosts>maven</nonProxyHosts>
    </proxy>
  </proxies>
</settings>

Proxy kullanmıyorsanız ve tarayıcıya olan bağlantıya erişebiliyorsanız, yukarıda açıklanan proxy ayarlarını kaldırın.


20
2018-03-11 09:05



Bu çözüm benim için çalıştı. Teşekkürler. - La-comadreja
Benim için de çok çalıştı :). teşekkür ederim - Raymond Nakampe


İlk hata için, yerel depoyu kontrol etmekten ziyade ana depodan yüklemeyi zorlamak için yerel depo önbelleğini temizleyebilirsiniz.

İkinci hata için, proxy'nin arkasındaysanız, bu şekilde yapılandırmalısınız. Bir proxy yapılandırılması aksi halde şimdi bir ağ sorununuz var.


5
2018-03-11 08:56



Cevabınız için teşekkürler.Maven temiz yükleme hatasız çalışıyor.Ama pom.xml içinde gösterilen aynı hata. - Sajith
NP. Sizde hatayı görüyor musunuz? POM veya içinde Maven console? - Sam Rad
Pom.xml dosyasında hata var. <Proje xmlns = "maven.apache.org/POM/4.0.0"; xmlns: xsi ="w3.org/2001/XMLSchema-instance"; xsi: schemaLocation ="maven.apache.org/POM/4.0.0  maven.apache.org/xsd/maven-4.0.0.xsd ">; - Sajith
Sorunuzu, tüm POM'unuzu dahil edecek şekilde düzenler misiniz? - Sam Rad


Bana göre, çözüm hatayı veren belirli bir klasörü yeni sildi. ~/.m2/repository/org/hsqldb/

Sildikten sonra hsqldb klasörü projeyi oluşturdum ve her şey yolunda.


3
2017-08-25 11:46



Bu benim için de çalıştı. STS kullanıyorum. Maven-update-force ... veya settings.xml gibi başka hiçbir şey işe yaramadı. Benim durumumda, bildirilen hata maven-surefire-plugin içindi. .M2 / repository / apache / org / maven / plugins / maven-plugins adresinde bulunan bu klasörü sildim. Bundan sonra projeyi temizledim ve bu hatayı pom.xml dosyasında kaldırdım. - Ankit


Bana yardımcı olan önerileri @carlspring (http proxy'nizi yapılandırmak için bir settings.xml oluşturun):

<?xml version="1.0" encoding="UTF-8"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" 
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
                              http://maven.apache.org/xsd/settings-1.0.0.xsd">

 <proxies>
    <proxy>
      <id>myproxy</id>
      <active>true</active>
      <protocol>http</protocol>
      <username>user</username>  <!-- Put your username here -->
      <password>pass</password>  <!-- Put your password here -->
      <host>123.45.6.78</host>   <!-- Put the IP address of your proxy server here -->
      <port>80</port>            <!-- Put your proxy server's port number here -->
      <nonProxyHosts>local.net|some.host.com</nonProxyHosts> <!-- Do not use this setting unless you know what you're doing. -->
    </proxy>    
  </proxies> 
</settings>

VE sonra @Peter T tarafından önerildiği gibi eclipse projesi maven ferahlatıcı:

Eclipse'deki "Anlık Görüntü / Sürümlerin güncellemesini zorla". Bu tüm hataları temizler. Projeyi sağ tıklayın -> Maven -> güncelleme projesi, ardından yukarıdaki seçeneği işaretleyin -> Tamam. Umarım bu size yardımcı olur.


3
2018-04-12 23:29





Görünüşe göre bir ağ sorunu vardı. Senin yanında ya da Maven tarafında ya da orda herhangi bir yerde. Sadece daha sonra tekrar deneyin.

Hata kalıcıysa, ağ ayarlarınızı kontrol edin. Bir proxy'nin arkasındaysanız, aşağıdakileri yapmanız gerekir: ~ / .m2 / settings.xml:

<proxies>
    <proxy>
        <id>optional</id>
        <active>true</active>
        <protocol>http</protocol>
        <username>proxyuser</username>
        <password>proxypass</password>
        <host>proxy.host.net</host>
        <port>80</port>
        <nonProxyHosts>local.net|some.host.com</nonProxyHosts>
    </proxy>
</proxies>

2
2018-03-11 08:53



answer.same için teşekkürler burada kullanılır. - Sajith


Nexus gibi Maven Repository Manager kullanmanız şiddetle tavsiye edilir. Maven ile istikrarlı ve tekrarlanabilir bir yapıya kavuşmanıza yardımcı olacaktır. Depo Yöneticisi genellikle LAN'ınızda olduğundan, proxy ayarlarını yapılandırmanız gerekmez, ancak başka yapılandırmaları tanımlamanız gerekir:

http://www.sonatype.com/books/nexus-book/reference/maven-sect-single-group.html

http://maven.apache.org/repository-management.html


2
2018-03-11 09:03