Soru Runtime.jar bulunamadı (android.arch.lifecycle: runtime: 1.0.0)


Ben koştuktan sonra ionic cordova build android Bu hatayı alıyorum:

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all files for configuration ':debugCompileClasspath'.
> Could not find runtime.jar (android.arch.lifecycle:runtime:1.0.0).
  Searched in the following locations:
  https://jcenter.bintray.com/android/arch/lifecycle/runtime/1.0.0/runtime-1.0.0.jar

Ve bu doğru. Bu URL'ye gittiğimde https://jcenter.bintray.com/android/arch/lifecycle/runtime/1.0.0/runtime-1.0.0.jar Anladım 404 Not found error JSON olarak.

Bu URL'de herhangi bir android / cordova özel sürümü göremiyorum, bu yüzden cordova kurulumumdan söz edemiyorum.

Cordova versiyonu: 7.1.0

İyonik bilgi:

cli packages: (C:\Users\%User%\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.19.2
    ionic (Ionic CLI) : 3.20.0

global packages:

    cordova (Cordova CLI) : not installed // this is strange. I can run cordova in my terminal tho

local packages:

    @ionic/app-scripts : 3.1.8
    Cordova Platforms  : android 6.4.0
    Ionic Framework    : ionic-angular 3.9.2

System:

    Android SDK Tools : 26.1.1
    Node              : v8.4.0
    npm               : 5.3.0
    OS                : Windows 10

Environment Variables:

    ANDROID_HOME : C:\Users\%User%\AppData\Local\Android\Sdk

Misc:

    backend : pro

Ayrıca hiç yok cordova-android  içindeki klasörler C:\Users\%USER%\.cordova\lib\npm_cache (Bu yardımcı olur mu bilmiyorum. İnsanların bu klasör hakkında konuştuğunu gördüm)

Sorun nedir burada? Bu URL nereden geliyor? Onu nasıl değiştirebilirim ve neyi değiştirebilirim?

Bunu kolayca çözemezsem yapılacak son bir adım var: her şeyi tekrar kaldırın ve kurun.

Teşekkür ederim!


39
2018-05-28 09:39


Menşei


Tepki-native run-android komutunu çalıştırdıktan sonra Native React üzerinde bu sorunu yaşıyorum. - Juni Brosas
Aynı günde tam olarak aynı sorunu olan birçok insan görebiliyorum. CDN sunucularında geçici bir sorun olabilir mi? - boyd
@boyd yep, everyones kırmaya karar verdi biri gibi görünüyor - octohedron
CompileSdkVersion yükseltmeyi deneyebilirsiniz. - 1van
Adamlarımı jcenter. Orada hayır dediler .jar orada dosya var. Sadece bir .aar dosya. - boyd


Cevaplar:


Hızlı bir geçici düzeltme, google maven repo'yu üst düzey gradle dosyanıza eklemektir.

allprojects {
  repositories {
      mavenLocal()
      maven { url 'https://maven.google.com' } // <-- add this!
      jcenter()

19
2018-05-28 10:35



Evet bu harika bir çözüm ve mantık. Bintray'ın lib ile ilgili bir sorunu var, bu yüzden başka bir bilgisayardan indirin. Teşekkürler - Vincent Menant
Bunu Benim React-Native projesinde denedim. Çalışmıyor. - JItendra Rana
jcenter.bintray.com/android/arch/lifecycle/runtime/1.0.0/...      Bu repo onun arıyor. Herhangi bir alternatif çözüm. - JItendra Rana
@JItendraRana: kendi-tepki-yerli-proje / android / build.gradle düzenlediğinizden emin olun ve jcenter ve allprojects grubundan önce yeni satırı ekleyin. - Moritz
Awesome benim için çalıştı - vinod8812


Benim için AIT MANSOUR ve Moritz cevaplar işe yaramadı, çünkü gereken diğer bağımlılıklar vardı jcenter() ve jitpackek olarak, için react-native ihtiyacın var node_modules.

Yani, benim çözümüm react-native olduğu

allprojects {
    repositories {
        // this is for native modules I'm developing
        mavenLocal()
        // for modules depending on jitpack.io
        maven { url "https://jitpack.io" }
        // add this one
        maven {
            url "https://maven.google.com"
        }
        maven {
            url "$rootDir/../node_modules/react-native/android"
        }
        // keep this at the end
        jcenter()
    }
}

10
2018-05-28 11:17



Bu tepki-yerli ile benim için çalıştı tek çözüm. Dedikleri npm paketlerini kullan, dedikleri kolay. Bunun ile SAAT SAAT! Teşekkürler octohedron! - Quintonn
Bir tedavi gibi çalıştım. Bu şekilde depolarınızı sipariş ederek, öncelikle kütüphaneleri Maven'den, daha sonra da yerel node_modules dizininizden çekiyorsunuz ve sonra bu ikisinde olmayan her şey jcenter'den çekilecek. Teşekkürler! - Joshua Pinter
Btw, işte aynı hatada popüler bir Github Sorunu bağlantısı var: github.com/zo0r/react-native-push-notification/issues/748 - Joshua Pinter
bu çözüm benim için çalıştı teşekkürler - V.Y.


Sorunu çözdüm (en azından benim için).

Öyle görünüyor ki jcenter Proje için kütüphaneler sağlayan bazı sorunlar var (geçici olabilir). Burada insanlar önerdiği gibi, bu kütüphaneleri maven'den alarak çözebilirsiniz.

Build.gradle dosyanıza gidin (iyonik dev'ler için / platformlar / android) ve kodun her satırının üstüne ekleyin. jcenter() bu hat maven { url 'https://maven.google.com' }.

Benim için iki yerdi: buildscript ve allprojects. Sonunda build.gradle dosyanızın üst kısmı şöyle görünmelidir:

apply plugin: 'com.android.application'

buildscript {
    repositories {
        maven { url "https://maven.google.com" }
        jcenter()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:3.0.0'
    }
}

allprojects {
    repositories {
        mavenLocal()
        maven { url 'https://maven.google.com' }
        jcenter()
    }
}

Bu ne yapar? Sadece kütüphane sağlayıcısını değiştirir (bu durumda jcenter) diğeriyle birlikte uygulamanız bunları başarıyla indirebilir. İçindeki her satır, geri dönüşü olan bir kütüphane sağlayıcısıdır.

İlk olarak maven için neden geri dönüş yapmadığını bilmiyorum çünkü geri dönüş sağlayıcısı build.gradle dosyasındaydı.


5
2018-05-28 11:50



build.gradle dosyasını manuel olarak güncellemek ister misiniz? - Rahul Upadhyay
Çalışmak için geçici bir çözümdür. Belki yarın jcenter mevcut olacak. - boyd
Sanırım "maven 'e geri dönüş" olmama sebebi, jcenter’de bir giriş bulmasıydı, ama gerekli olanı bulamıyor. .jar dosya. Yani "orada" ama belirli bir .jar ihtiyaç duyduğu dosya değil, jcenter'ın bunun için bir listeye sahip olmaması farklı. Jcenter'a göre, sadece .aar Bu kütüphane için dosya değil .jar. - Joshua Pinter
Benim durumumda, jcenter () ifadesi maven üzerinde ve bu yüzden benim uygulama çöküyordu. Bu ipucu problemi çözdü! - ECC


Bu sabah aynı problemi yaşadım:

    Error:Could not resolve all files for configuration ':app:debugAndroidTestRuntimeClasspath'.

Runtime.jar bulunamadı (android.arch.lifecycle: runtime: 1.0.0).     Aşağıdaki yerlerde arandı:          https://jcenter.bintray.com/android/arch/lifecycle/runtime/1.0.0/runtime-1.0.0.j

Bu şekilde düzelttim: Proje deposunda, build.gradle dosyasını düzenledim, jcenter () yorumunu yaptım:

repositories {
   // jcenter()
    maven {
        url "https://maven.google.com"
    }
}

Şimdi proje başarıyla inşa ediyor! İyi şanslar !


4
2018-05-28 10:42



Hangi gradle uygulaması / build.gradle veya build.gradle ?? - AndyBoy
Sadece mevcut olan kütüphanelere ihtiyaç duyabileceğine dair yorum yapmaya gerek yok jcenter(). Aşağıdan aşağıya taşıyabilirsiniz maven. Ancak, siz yorum yaparsanız ve işe yarıyorsa, bu muhtemelen kaldırmanız anlamına gelir jcenter() Tamamen bu depodaki kütüphanelere bağlı olmadığınız için. - Joshua Pinter


Android / build.gradle’de kodu aşağıdaki gibi değiştirin -

   allprojects {
    repositories {
        mavenLocal()
        maven { url 'https://maven.google.com' }
        jcenter()
        maven {
            // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
            url "$rootDir/../node_modules/react-native/android"
        }
    }
}

4
2018-05-28 10:48



Bunu React-Native projelerinde denedim. Çalışmıyor. - JItendra Rana
projenizi paylaşabilir mi? - Sidharth Taneja
@JItendraRana Taşınmayı deneyin jcenter() listenin sonuna "node_modules" den sonra maven listeleme. - Joshua Pinter


Bu benim için iş sadece bu iki adımı takip et

Aşama 1: Projede build.gradle dosya sadece aşağıdaki kodu değiştir

 allprojects {
      repositories {
          mavenLocal()
          maven { url 'https://maven.google.com' }
          jcenter()
//        google()
    }
}

Sadece yorum yap Google() Proje gradle dosyasında varsa.

Adım 2: Dosyada gradle-wrapper.properties düşürmek distributionUrl aşağıdan aşağıya doğru sadece aşağı doğru.

 distributionUrl=https\://services.gradle.org/distributions/gradle-4.0-all.zip

1
2018-05-28 11:28



Sanmıyorum gradle-wrapper.properties Bununla ilgili bir şey var. - Joshua Pinter


Sorun şu ki, pom jcenter üzerinde listelenmiş, ancak kavanoz eksik.

https://jcenter.bintray.com/android/arch/lifecycle/runtime/1.0.0/

Meta veriler bir repoda mevcutsa ancak artefakt eksikse not başarısız olur

https://github.com/gradle/gradle/issues/1120

@ Moritz'in düzeltmesi, önce maven.google.com adresine giderek çalışmalıdır.


0
2018-05-28 10:44





Android platformunu kaldırdım ve tekrar ekledim: ayırmak:

cordova platformu rm android

eklemek:

cordova platformu ekle android

ve şimdi her şey güzel Not: Android'in bu sürümü bu sefer doğru bir şekilde yüklenmedi (bugünden önce yaptım!)

cordova platformu ekle android@6.1.0


0
2018-05-28 12:37





Ben de aynı hatayı alıyorum.

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Build.gradle'da hiçbir şeyi değiştirmedim.


0
2018-05-29 09:45



Build.gradle dosyasıyla ilgili bir sorun değil. Sorun jcenter () ile. Bazı kütüphaneler için 404 ile yanıt veriyor. Yukarıda belirtilen geçici düzeltmeyi deneyin. - boyd
@Moritz'i ve onun cevabını iyi çalıştı. - AndyBoy
Evet, çünkü bu değişiklikle dosyalarınızı maven.google.com - boyd
Yani, hangi dosyaların jcenter () yerine maven çekiyor demek istiyorsun? - AndyBoy


Yeni bir sürümü cordova-android Bu sorunu çözen (7.1.1) yayınlandı.

Mevcut android platformunu kaldır

cordova platform rm android

Ve yeni platformu ekle

cordova platform add android@7.1.1

0
2017-07-16 15:00